A clear name for an extension method?












0












$begingroup$


I have created an extension method for the Vector2 type available in the SharpDX libraries. The purpose of this method is to determin if a specified point is occluded from the camera's view and thus is named IsOccluded. Since extension methods are static methods with an additional way to call them, the naming seems odd if I use the containing class to call the method (which is completely possible):



public static bool IsOccluded(this Vector2 point, Matrix world) { }


Since this is the case, it seems odd when calling it from the containing class:



RenderingUtilities.IsOccluded(Vector2, Matrix)


Versus calling it as intended:



Vector2 point;
bool occluded = point.IsOccluded(world);


I am wondering what a proper name would be to cover both cases so that it is neither redundant nor confusing as to what is going on. I originally thought that perhaps IsPointOccluded would work (which for calling from the containing class it does), but it doesn't in the case of using it as an extension: point.IsPointOccluded.





Is the name IsPointOccluded clearly understood in both scenarios, or does it seem a little redundant?



What would be a better name that could cover both scenarios?










share|improve this question









$endgroup$












  • $begingroup$
    IsPointOccluded is a good name, I'd use it.
    $endgroup$
    – Maxim
    6 hours ago
















0












$begingroup$


I have created an extension method for the Vector2 type available in the SharpDX libraries. The purpose of this method is to determin if a specified point is occluded from the camera's view and thus is named IsOccluded. Since extension methods are static methods with an additional way to call them, the naming seems odd if I use the containing class to call the method (which is completely possible):



public static bool IsOccluded(this Vector2 point, Matrix world) { }


Since this is the case, it seems odd when calling it from the containing class:



RenderingUtilities.IsOccluded(Vector2, Matrix)


Versus calling it as intended:



Vector2 point;
bool occluded = point.IsOccluded(world);


I am wondering what a proper name would be to cover both cases so that it is neither redundant nor confusing as to what is going on. I originally thought that perhaps IsPointOccluded would work (which for calling from the containing class it does), but it doesn't in the case of using it as an extension: point.IsPointOccluded.





Is the name IsPointOccluded clearly understood in both scenarios, or does it seem a little redundant?



What would be a better name that could cover both scenarios?










share|improve this question









$endgroup$












  • $begingroup$
    IsPointOccluded is a good name, I'd use it.
    $endgroup$
    – Maxim
    6 hours ago














0












0








0





$begingroup$


I have created an extension method for the Vector2 type available in the SharpDX libraries. The purpose of this method is to determin if a specified point is occluded from the camera's view and thus is named IsOccluded. Since extension methods are static methods with an additional way to call them, the naming seems odd if I use the containing class to call the method (which is completely possible):



public static bool IsOccluded(this Vector2 point, Matrix world) { }


Since this is the case, it seems odd when calling it from the containing class:



RenderingUtilities.IsOccluded(Vector2, Matrix)


Versus calling it as intended:



Vector2 point;
bool occluded = point.IsOccluded(world);


I am wondering what a proper name would be to cover both cases so that it is neither redundant nor confusing as to what is going on. I originally thought that perhaps IsPointOccluded would work (which for calling from the containing class it does), but it doesn't in the case of using it as an extension: point.IsPointOccluded.





Is the name IsPointOccluded clearly understood in both scenarios, or does it seem a little redundant?



What would be a better name that could cover both scenarios?










share|improve this question









$endgroup$




I have created an extension method for the Vector2 type available in the SharpDX libraries. The purpose of this method is to determin if a specified point is occluded from the camera's view and thus is named IsOccluded. Since extension methods are static methods with an additional way to call them, the naming seems odd if I use the containing class to call the method (which is completely possible):



public static bool IsOccluded(this Vector2 point, Matrix world) { }


Since this is the case, it seems odd when calling it from the containing class:



RenderingUtilities.IsOccluded(Vector2, Matrix)


Versus calling it as intended:



Vector2 point;
bool occluded = point.IsOccluded(world);


I am wondering what a proper name would be to cover both cases so that it is neither redundant nor confusing as to what is going on. I originally thought that perhaps IsPointOccluded would work (which for calling from the containing class it does), but it doesn't in the case of using it as an extension: point.IsPointOccluded.





Is the name IsPointOccluded clearly understood in both scenarios, or does it seem a little redundant?



What would be a better name that could cover both scenarios?







c#






share|improve this question













share|improve this question











share|improve this question




share|improve this question










asked 6 hours ago









PerpetualJPerpetualJ

1418




1418












  • $begingroup$
    IsPointOccluded is a good name, I'd use it.
    $endgroup$
    – Maxim
    6 hours ago


















  • $begingroup$
    IsPointOccluded is a good name, I'd use it.
    $endgroup$
    – Maxim
    6 hours ago
















$begingroup$
IsPointOccluded is a good name, I'd use it.
$endgroup$
– Maxim
6 hours ago




$begingroup$
IsPointOccluded is a good name, I'd use it.
$endgroup$
– Maxim
6 hours ago










0






active

oldest

votes











Your Answer





StackExchange.ifUsing("editor", function () {
return StackExchange.using("mathjaxEditing", function () {
StackExchange.MarkdownEditor.creationCallbacks.add(function (editor, postfix) {
StackExchange.mathjaxEditing.prepareWmdForMathJax(editor, postfix, [["\$", "\$"]]);
});
});
}, "mathjax-editing");

StackExchange.ifUsing("editor", function () {
StackExchange.using("externalEditor", function () {
StackExchange.using("snippets", function () {
StackExchange.snippets.init();
});
});
}, "code-snippets");

StackExchange.ready(function() {
var channelOptions = {
tags: "".split(" "),
id: "196"
};
initTagRenderer("".split(" "), "".split(" "), channelOptions);

StackExchange.using("externalEditor", function() {
// Have to fire editor after snippets, if snippets enabled
if (StackExchange.settings.snippets.snippetsEnabled) {
StackExchange.using("snippets", function() {
createEditor();
});
}
else {
createEditor();
}
});

function createEditor() {
StackExchange.prepareEditor({
heartbeatType: 'answer',
autoActivateHeartbeat: false,
convertImagesToLinks: false,
noModals: true,
showLowRepImageUploadWarning: true,
reputationToPostImages: null,
bindNavPrevention: true,
postfix: "",
imageUploader: {
brandingHtml: "Powered by u003ca class="icon-imgur-white" href="https://imgur.com/"u003eu003c/au003e",
contentPolicyHtml: "User contributions licensed under u003ca href="https://creativecommons.org/licenses/by-sa/3.0/"u003ecc by-sa 3.0 with attribution requiredu003c/au003e u003ca href="https://stackoverflow.com/legal/content-policy"u003e(content policy)u003c/au003e",
allowUrls: true
},
onDemand: true,
discardSelector: ".discard-answer"
,immediatelyShowMarkdownHelp:true
});


}
});














draft saved

draft discarded


















StackExchange.ready(
function () {
StackExchange.openid.initPostLogin('.new-post-login', 'https%3a%2f%2fcodereview.stackexchange.com%2fquestions%2f211944%2fa-clear-name-for-an-extension-method%23new-answer', 'question_page');
}
);

Post as a guest















Required, but never shown

























0






active

oldest

votes








0






active

oldest

votes









active

oldest

votes






active

oldest

votes
















draft saved

draft discarded




















































Thanks for contributing an answer to Code Review Stack Exchange!


  • Please be sure to answer the question. Provide details and share your research!

But avoid



  • Asking for help, clarification, or responding to other answers.

  • Making statements based on opinion; back them up with references or personal experience.


Use MathJax to format equations. MathJax reference.


To learn more, see our tips on writing great answers.




draft saved


draft discarded














StackExchange.ready(
function () {
StackExchange.openid.initPostLogin('.new-post-login', 'https%3a%2f%2fcodereview.stackexchange.com%2fquestions%2f211944%2fa-clear-name-for-an-extension-method%23new-answer', 'question_page');
}
);

Post as a guest















Required, but never shown





















































Required, but never shown














Required, but never shown












Required, but never shown







Required, but never shown

































Required, but never shown














Required, but never shown












Required, but never shown







Required, but never shown







Popular posts from this blog

Список кардиналов, возведённых папой римским Каликстом III

Deduzione

Mysql.sock missing - “Can't connect to local MySQL server through socket”